94 Labaron clock

Discussion in 'General Motoring' started by clams, Oct 24, 2010.

  1. clams

    clams Guest

    The clock / radio in my 94 LaBaron works one day and then after a few days
    it is blank. It started a few months ago. I doubt that it's a simple
    loose connection, because the on / off does not occur while driving (rough
    road, etc). It's more likely to be off when starting after a few days lack
    of use and then suddenly be working upon starting several days later and
    work fine until it's parked a few days.

    Any suggestions? No big deal, perhaps more curiosity than anything else.
     
    clams, Oct 24, 2010
    #1
    1. Advertisements

  2. clams

    KirkM Guest

    Is it just the display, or does the clock no longer keep time, and the
    radio no longer work?

    I would suggest replacing with an aftermarket unit, or find a used OEM
    unit. I found a perfectly working OEM AM/FM Cassette for my mid-90's
    minivan at a thrift store for only $2.00.

    A repair shop could probably fix it for you, but they will probably
    want some cash up front to find out what is wrong, and will usually
    apply it to the repair cost should you decide to let them fix it.

    KM
     
    KirkM, Oct 27, 2010
    #2
    1. Advertisements

  3. It could be a bad connection that a bumpy rough road shakes the
    connection into making a contact. If the radio is turned on, but not
    playing see if whacking the dash as close to the radio as possible
    causes it to play.
     
    Pete E. Kruzer, Oct 27, 2010
    #3
  4. clams

    clams Guest

    Is it just the display, or does the clock no longer keep time, and the
    radio no longer work?

    Clock no longer keeps time & radio / cassette stop working. One day it
    works fine and after a few days it does not work upon starting. Then after
    a few days it works again upon starting.

    It never starts up while driving or from what I've seen stops while driving.
    As I mentioned, it's no big deal as I rarely use the radio, but like having
    the clock.


    I would suggest replacing with an aftermarket unit, or find a used OEM
    unit. I found a perfectly working OEM AM/FM Cassette for my mid-90's
    minivan at a thrift store for only $2.00.

    A repair shop could probably fix it for you, but they will probably
    want some cash up front to find out what is wrong, and will usually
    apply it to the repair cost should you decide to let them fix it.

    KM
     
    clams, Oct 28, 2010
    #4
  5. I have the same problem on my 91 aclaim. I know the problem is
    electrical since it happen right after I changed heater core. My
    interior light is not working also.

    I will open the dash to see the wires.

    good luck to you
     
    ulas c coskun, Oct 28, 2010
    #5
    1. Advertisements

Ask a Question

Want to reply to this thread or ask your own question?

You'll need to choose a username for the site, which only take a couple of moments (here). After that, you can post your question and our members will help you out.