2000 Dodge Neon Weird Brake Issue

Discussion in 'Neon' started by ULB, Aug 31, 2007.

  1. ULB

    ULB Guest

    Hi folks,

    I have a 2000 Dodge Neon that on occasion, usually in the morning,
    that while backing up, the brakes act as though the the power booster
    has gone out. Meaning it is VERY hard to get the car to stop.

    This problem has never occured going forward, and always when the car
    is first started up (say first 45 seconds). This issue occurs at
    random, and is difficult to reproduce.

    What should I be looking at? Vacuum lines? I replaced from and rear
    pads and shoes about 4 months ago.

    Thanks for any insight!
     
    ULB, Aug 31, 2007
    #1
    1. Advertisements

  2. ULB

    maxpower Guest

    The brake booster vacuum hose may be leaking causing this, There was a
    recall out for this problem on your vehicle, Recall#983. was it done? if you
    e mail me the last 8 of the vin number I can let you know if it is an
    incomplete recall on your vehicle

    Glenn Beasley
    Chrysler Tech
     
    maxpower, Aug 31, 2007
    #2
    1. Advertisements

  3. ULB

    ULB Guest

    Hi Glenn,

    I went and read up on that recall. Being a hose from the manifold
    going to the power booster. Sure as heck, the mouth of the hose
    closest to the power booster was expanded and when the car was running
    I could hear it sucking air fairly loudly. I cut off a 3/4" slice and
    put it back on and bammo, no more vacuum leak.

    Thanks!
     
    ULB, Sep 4, 2007
    #3
  4. ULB

    maxpower Guest

    Kewl.
     
    maxpower, Sep 5, 2007
    #4
    1. Advertisements

Ask a Question

Want to reply to this thread or ask your own question?

You'll need to choose a username for the site, which only take a couple of moments (here). After that, you can post your question and our members will help you out.